Naming Convention (OpenInsight 32-bit Specific)
At 11 MAY 2004 02:30:11AM Calvin Aw wrote:
Hi Guys,
May I know how your naming convention looks like when developing software in OI?
The areas I am interested in are :
Form, Button, Edit Line, Edit Box, Edit Table, Tab, Popups as well as Stored Procedures.
Thanks.
Best Regards,
Calvin.
At 11 MAY 2004 10:01AM The Sprezzatura Group Web Site wrote:
Ermmm why would you be interested in our naming conventions and not our programming standards when the former are so clearly predicated by the latter?
![]()
Forms we normally call by the most logical word(s) to describe the function of the form.
Button :- BTN_ except for special cases intercepted by promoted events
Edit Line :- EDL_ ditto
Edit Table :- EDT_ ditto
Tab :- don't use OI tabs
Popups :- See forms
SPs :- name of form if a commuter module otherwise prefixes based upon purpose.
support@sprezzatura.com
The Sprezzatura Group Web Site
World Leaders in all things RevSoft
At 11 MAY 2004 01:15PM Richard Hunt wrote:
For forms, basically I have a few rules I follow. Entry forms start with "ENTER_". Inquiry forms start with "INQUIRE_". Posting forms start with "POST_". Report forms start with "REPORT_". Unposting forms start with "UNPOST_". Also the actual module is then appended. For Freight Billing append "FB". For Cash Receipts append "CR". For Interline Payable append "IL". For Subhaul Payable append "SH". For Owner Operator payable append "OO".
The actual items within a form, I use something very simple. If I was working with a name entry, I would name the "TEXT" control "NAME_TEXT", and the "EDITLINE" simply "NAME". No matter what the control type is. Within the stored proceedure I would use variables like this, NAME_FOCUS=@WINDOW:'.NAME'
For stored proceedures, I have some that are standard events. Like "CREATE", used for all create events, and is named "CREATE_WINDOW". Or "CLOSE", used for all close events, and is named "CLOSE_WINDOW". Now for the stored proceedures for the forms I use "EVENTS_" and then append the form name. For the UDC (user defined conversions I use "CONV_" and for the location conversion I would append "LOCATION".